move to .impl package