terminal: update jediterm to 3.5, cleanup