Remove obsolete dependencies from student and educational-core