[git] Substitute trilead-ssh2 library with the patched one