mutcianm/IDEA-293570
authorMikhail Mutcianko <mikhail.mutcianko@jetbrains.com>
Wed, 18 May 2022 15:21:55 +0000 (15:21 +0000)
committerintellij-monorepo-bot <intellij-monorepo-bot-no-reply@jetbrains.com>
Wed, 18 May 2022 15:21:55 +0000 (15:21 +0000)
commit7aec5735153c2e531ac42691d3c81b3dfd2375cc
treed0fb52fce58fb3855f670ae6acd4bf411f6d3214
parentd1271dbd3565ea3abdf84e21220f1aa78745e001
mutcianm/IDEA-293570
[plugins] increase verbosity of warnings in PluginRepositoryAuthService IDEA-293570

[plugins] drop domain checks in PluginRepositoryAuthService IDEA-293570

it was decided that these security limitations are an overkill and do not solve any practical issues

Merge-request: IJ-MR-24467
Merged-by: Mikhail Mutcianko <mikhail.mutcianko@jetbrains.com>
GitOrigin-RevId: 94a342d3765cca42ae614a7c904616c218d431a0
platform/platform-impl/src/com/intellij/ide/plugins/auth/PluginRepositoryAuthService.kt
platform/platform-tests/testSrc/com/intellij/ide/plugins/ExternalAuthContributorServiceTest.kt