Merge branch 'slava/plugin-incompatible-with'
[idea/community.git] / platform / platform-impl / src / com / intellij / ide / plugins / PluginNode.java
index c9cce1357126947347ef1ec7ce13d4eb569d9f0c..3a7245b7085157ea219ab5bce9890950b65bdfcf 100644 (file)
@@ -7,6 +7,7 @@ import org.jetbrains.annotations.Nullable;
 
 import java.nio.file.Path;
 import java.util.ArrayList;
+import java.util.Collections;
 import java.util.Date;
 import java.util.List;
 
@@ -114,6 +115,11 @@ public final class PluginNode implements IdeaPluginDescriptor {
     return licenseOptional;
   }
 
+  @Override
+  public @NotNull List<PluginId> getIncompatibleModuleIds() {
+    return Collections.emptyList();
+  }
+
   public void setLicenseOptional(boolean optional) {
     this.licenseOptional = optional;
   }