package correction
[idea/community.git] / update-server-mock / build.gradle
1 buildscript {
2   repositories { jcenter() }
3   dependencies {
4     classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:+"
5   }
6 }
7
8 apply plugin: 'kotlin'
9
10 repositories { jcenter() }
11 dependencies {
12   compile "org.jetbrains.kotlin:kotlin-stdlib:1.0.+"
13   testCompile "junit:junit:4.+"
14   testCompile "org.assertj:assertj-core:3.+"
15 }
16
17 jar {
18   manifest {
19     attributes "Main-Class" : "com.intellij.updater.mock.MainKt"
20   }
21   from {
22     configurations.compile.collect { it.isDirectory() ? it : zipTree(it) }
23   }
24 }