bde33953db4a953938405a3a3181c21e3ff4294e
[idea/community.git] / platform / platform-tests / testData / plugins / sort / simplePluginSort.txt
1 + com.intellij
2   cycle3
3   cycle1
4   cycle2
5   cycle0
6   cycle4
7   cycle5
8 + duplicate
9 + duplicate0
10   missing1
11   missing2
12   missing3
13 + optional_config_cycle1
14   optional_config_cycle0
15   optional_config_cycle2
16   optional_cycle2
17   optional_cycle0
18   optional_cycle1
19 + plugin3
20 + plugin0
21 + plugin1
22 + plugin2
23
24 Plugin "incompatible0" is incompatible (until build 1.111111 < 2042.42).
25 Plugin "incompatible0-alt" is incompatible (until build 1.111 < 2042.42).
26 Plugin "incompatible1" is incompatible (since build 9999.0 > 2042.42).
27 Plugin "incompatible2" is incompatible (until build 1.111111 < 2042.42).
28 Plugin "missing4" is incompatible (supported only in IntelliJ IDEA).
29 Module com.intellij.modules.duplicate is declared by plugins:
30   PluginDescriptor(name=duplicate0, id=duplicate0, path=file:/duplicate0.xml)
31   PluginDescriptor(name=duplicate, id=duplicate, path=file:/duplicate1.xml).
32 Plugins should not have cyclic dependencies: optional_cycle1 <-> optional_cycle2 <-> optional_cycle0, cycle5 <-> cycle4, cycle2 <-> cycle3 <-> cycle1.
33 Plugin "missing2" requires "com.intellij.missing" plugin to be installed.
34 Plugin "missing3" requires "missing2" plugin to be enabled.
35 Plugin "missing1" requires "com.intellij.modules.missing" plugin to be installed.
36 Plugin "cycle0" requires "cycle1" plugin to be enabled.
37 <br><a href="disable">Disable not loaded plugins</a>
38 <a href="edit">Open plugin manager</a>