Updating versions of project dependencies: jdkBuild->11_0_8b1098.1
[idea/community.git] / java / idea-ui / src / com / intellij / ide / util / importProject / LibrariesLayoutPanel.java
index e96f463040e8e11d53786d8784b997e0eb59b3a5..b6f1afd606955a3b6ee5d5b9fc8bde777f88cf3d 100644 (file)
@@ -2,6 +2,7 @@
 package com.intellij.ide.util.importProject;
 
 import com.intellij.ide.JavaUiBundle;
+import com.intellij.openapi.util.NlsContexts;
 
 import java.io.File;
 import java.util.Collection;
@@ -70,13 +71,18 @@ public class LibrariesLayoutPanel extends ProjectLayoutPanel<LibraryDescriptor>{
   }
 
   @Override
-  protected String getDependenciesTitle() {
+  protected @NlsContexts.BorderTitle String getDependenciesTitle() {
     return JavaUiBundle.message("title.library.contents");
   }
 
   @Override
-  protected String getElementTypeName() {
-    return "library";
+  protected String getElementTypeNamePlural() {
+    return JavaUiBundle.message("title.libraries");
+  }
+
+  @Override
+  protected ElementType getElementType() {
+    return ElementType.LIBRARY;
   }
 
   @Override